Openfax Website
Incident Report for Openfax
Resolved
The backend database issue has been resolved.
Posted Aug 31, 2017 - 12:59 MDT
Identified
The traditional Openfax.com website is experiencing backend database issues. This incident does NOT impact the Openfax fax or email networks. A temporary landing page has provided access to your account services while our team repairs the issue.
Posted Aug 31, 2017 - 12:56 MDT