Some inbound call failure issue with underlying carrier
Incident Report for Openfax
Resolved
Our underlying carrier has identified the issue and they have implemented a fix at 9:15 AM US CENTRAL - we continue to monitor the calls.
Posted Jul 17, 2018 - 08:55 MDT
Investigating
Since Jul 17, 2018 06:01:00 AM US Central we noticed traffic decline from one of our underlying carriers. Some customers are affected with intermittent inbound call failures as our underlying carrier is experiencing routing issues with their system. The issue has been escalated to the highest level and we will continue to monitor.

Updates to follow.
Posted Jul 17, 2018 - 07:27 MDT
This incident affected: Inbound Fax Service.